Customer Support Phone and Chat Support Unavailable
Incident Report for Sansar
Resolved
The Sansar chat and phone support issue has been resolve. Phone, chat and cases submission is available.
Posted 10 months ago. Feb 16, 2018 - 13:11 PST
Update
The Sansar chat and phone support issue has been resolve. Phone, chat and cases submission is available.
Posted 10 months ago. Feb 16, 2018 - 13:09 PST
Investigating
Investigating - Sansar chat and phone support is currently unavailable, today February 16th, 2018. We are currently investigating this matter. Case submissions are still available.
Posted 10 months ago. Feb 16, 2018 - 06:46 PST
This incident affected: Support (Cases).