International Card Add & Payment Issues
Incident Report for Sansar
Resolved
Non-US users should now be able to add and use cards for payment. Thank you for your patience.
Posted 4 months ago. Mar 21, 2019 - 14:39 PDT
Investigating
We are experiencing an issue with adding international cards for payments. Non-U.S. users are not currently able to add cards. Non-U.S. users who have already added their cards may also see failures to complete payments. A fix is being worked on, but there is currently no estimate as to when it will be completed. Please stay tuned for updates and thank you for your patience.
Posted 4 months ago. Mar 21, 2019 - 13:59 PDT