International Card Add Issues
Incident Report for Sansar
Resolved
Non-US users should now be able to add cards for payment. Thank you for your patience.
Posted 11 months ago. Sep 19, 2018 - 06:30 PDT
Investigating
We are experiencing an issue with adding international cards for payments. Non-U.S. users are not currently able to add cards. However, non-U.S. users who have already added their cards should still be able to use these. A fix is being worked on, but there is currently no estimate as to when it will be completed. Please stay tuned for updates and thank you for your patience.
Posted 11 months ago. Sep 18, 2018 - 13:49 PDT