Sansar Dollar Issues on Steam
Incident Report for Sansar
Resolved
Sansar for Steam users should now be able to make purchases with Sansar Dollars as normal. Thank you again for your patience.
Posted 3 months ago. Apr 19, 2019 - 14:57 PDT
Identified
It has come to our attention that Steam users have been unable to make Sansar Dollar purchases for the past several days. The issue has been noted and a fix is being implemented. Thank you for your patience.
Posted 3 months ago. Apr 19, 2019 - 14:36 PDT
This incident affected: Sansar Services (Store Purchases).