Web Outage
Incident Report for Sansar
Resolved
Web issue is now resolved.
Posted over 1 year ago. Feb 22, 2018 - 13:38 PST
Investigating
Sansar.com is currently experiencing an outage. We are aware of this situation and will update this blog when the issue has been resolved.
Posted over 1 year ago. Feb 22, 2018 - 12:58 PST
This incident affected: Websites (atlas.sansar.com, exchange.sansar.com, help.sansar.com, store.sansar.com).